Create  Edit  Diff  RDEマニュアル  Index  Search  Changes  History  Source  RSS  wikifarm  Login

日本語設定

RDEの設定

メニューの日本語表示

ここではメニューの日本語表示を行います。

メニューの Tool -> Options で起動時に表示されたダイアログが表示されます。 表示されたダイアログの左側の列の「Config File」を選択すると、 下の図のように各種設定ファイルを指定する画面が表示されます。 その中の一番上の TranslationFile? に RDE がインストールされた場所の 「Translations\Japanese_XXXX.xml」(Xは数字)を翻訳ファイルとして指定します。

rde_translation.jpg

上の図は RDE を C:\Program Files\RDE にインストールした場合です。 他の場所に RDE をインストールした場合は適宜変更する必要があります。

適切な翻訳ファイルを指定してダイアログの「Submit」を押して RDE を再起動すればメニューが日本語表示になっているはずです。

エディタの日本語表示

最初はエディタ部分に日本語を表示することが出来ないかもしれません。

その場合はメニューの ツール -> エディタ設定 を選び、 表示タブ の一番上にあるフォントと書かれたボタンを押します。 こうすることで下図のようなフォント選択のダイアログが出ます。

rde_editor_font.jpg

好みのフォントが無ければ下記のようにすれば良いでしょう。

フォント名 MS ゴシック
スタイル 標準
サイズ 10
書体の種類 日本語

ファイル保存時の文字コード

何も考えたくない場合は下記のようにしてください。

  1. メニュー の ツール -> 設定 を選ぶ
  2. コードウィンドウ -> 文字コード変換 を選ぶ
  3. 追加 のボタンを押す
  4. RDE のインストール先の japanese.dll を選択
  5. コードウィンドウ -> 文字コード を選ぶ
  6. 標準文字コードを デフォルト から SJIS に変更

Ruby の Help との連動

RDE から Ruby の Windows HTML Help を使うことが出来ます。

http://elbereth-hp.hp.infoseek.co.jp/ruby.html

から ruby-refm-rdp-1.8.1-ja-htmlhelp.zip をダウンロードします。ダウンロードしたファイルを解凍して、 中の rubymanjp.chm を RDE のインストール先にコピーします。 これでメニューの ヘルプ -> Rubyヘルプ から Ruby の HTML Help を使うことが出来るようになります。

Last modified:2005/09/28 03:56:39
Keyword(s):
References:[jp/top]